CompatibilityΒΆ

Utilizing the six library for Python 2 and 3 compatibility. More work and testing needs to be done to confirm Python 3 compatibility